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10. Reaction Equations Module 
 
 

 
 
SUMMARY 
 
Clicking the Reaction Equations button in the main menu of HSC shows the Reaction 
Equations Window, see Fig. 1. With this module you can calculate the heat capacity, 
enthalpy, entropy and Gibbs energy values of a single species as well as of specified 
reactions between pure substances. The module also enables graphing of the results as a 
function of temperature. 
 
See the reference state definitions, valid notations, and abbreviations for the description of 
the chemical formulae in Chapter 28 (section 28.2). 
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10.1. One Chemical Substance 
 

 
Fig. 1. Reaction Equations window of HSC Chemistry. 

By entering a single chemical formula into the Formula box you will get similar tables of 
thermochemical data as presented in many thermochemical data books. HSC will, however, provide 
the results faster and exactly at the temperatures which you really want. Calculate also produces a 
chart which allows the results to be seen in graphical form as well. Please follow these steps: 

1. Write a chemical formula in the formula box, (top left in Fig. 1) 
 For example: Fe, Na2SO4, Al2O3, SO4(-a), H(+a) or SO2(g). 
 See the valid notation and syntax of chemical formulae in Chapter 28 (section 28.2). 
2. Select the lower limit, upper limit and temperature step. 
3. Select the Temperature and Energy Units and the format of the results (Normal or 

Delta) from the "Options" menu. 
 
 Normal (Absolute scale): 
 H(species), S(species) and C(species) 
 This format is used for example in the famous I. Barin, O. Knacke, and O. 

Kubaschewski data compilation1. 
 
 Delta (Formation functions): 
 

ΔH = H(species) - Σ H(elements) 
ΔS = S(species) - Σ S(elements) 
ΔG = G(species) - Σ G(elements)  
ΔG = G(ions) - Σ G(elements) + z/2·G(H2(g)) - z·G(H(+a)) 
z = charge. 

 
 This format is used for example in the NBS and Pankratz Tables2,3. 
 

4. The Collect Data option will collect several calculation results on different sheets. 
Data from these sheets can be plotted into a single chart by using the Plot all data 
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option in Chart Options. The Plot all data feature requires that the calculations of 
different sheets use the same units (energy and temperature) and also that they are 
in the same format (Normal or Delta, affects only pure substance calculations). Pure 
substance calculations and reaction calculations cannot be plotted in the same graph. 

5. Select Show Transitions from the "Options" menu if you also want to see the data at 
the phase transformation temperatures, such as crystal structure changes and 
melting. 

6. Select Criss-Cobble from the "Options" menu if you want a Criss-Cobble 
extrapolation for the heat capacity of aqueous species, see Chapter 28 (section 28.4.) 

7. Click Calculate to get the results on the screen. 
8. Click Print from the "File" menu to print the results. 
9. Click Copy Sheet from the "Sheet" menu to get the tabulated results into the 

Clipboard, then you can easily paste the results to other Windows applications, for 
example, to MS Excel. It is possible to copy and paste the content of individual cells 
to other applications using Copy. 

10. Click Save As... from the "File" menu to save the entire workbook as an .rea8 file. 
These files can be opened for later use with Open... from the "File" menu. 

 
Note: 
 
1. It is easy to check the basic data that has been used in the reaction module 

calculations from the database. In Fig. 1, select the formula in the Reaction Equation 
box and press Browse.... 

2. The table in Fig. 1 has some formatting and Copy - Paste functions as do other tables 
in HSC Chemistry. These features help to create a good printed copy of the results 
for various purposes. 

3. HSC searches for the species data first from the Own database. If it does not find a 
species there, it will search from the Main database. Therefore HSC always uses 
data in the Own database if the same species exists in both Own and Main 
databases. 

4. If you have selected Delta format for the results, HSC will also search for data for the 
necessary elements and calculate the formation functions of enthalpy, entropy, and 
Gibbs energy. Usually the original experimental data is in this format: however, 
sometimes the comparison of data in this format may be more difficult because the 
data sources often use different data for elements. 

5. HSC will make a Criss-Cobble extrapolation for the heat capacity of aqueous 
species at elevated temperatures (> 25 °C) if the Criss-Cobble option is selected. The 
extrapolation is not done if A and B of the heat capacity coefficients A, B, C, and D 
exist in the HSC Chemistry databases. The extrapolation error increases rapidly at 
higher temperatures. More information on extrapolation is given in Chapter 28 (28.4.) 

6. For aqueous species it is recommended to set: 
 Lower temperature = 25 °C 
 Upper temperature = 300 °C 
 Step   = 25 °C 
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10.2. One Chemical Substance Results 
 
After pressing the Calculate button in Fig. 1, you will get the results in a table in the lower 
part of the window as well as a graph for a single property. You can save and print these 
results by using options found in the File and Edit menus: 
1. Click Save As... if you wish to recalculate the results later. The Save As... function 

will also save the settings used in Fig. 1. You can read these files back to HSC using 
File Open. 

2. Click Print if you want a paper copy. 
3. Click Copy to put the results of selected cells into the Clipboard, then you can easily 

paste the results, for example, to MS Excel. Click Copy Sheet to put all the results of 
the sheet into the Clipboard. 

4. Click Export To Excel to save the entire workbook, containing several sheets, in MS 
Excel format. 

5. Click Copy Chart from the "Edit" menu to copy the chart to the clipboard, from where 
the graph can be pasted for example into MS Word.  

6. Click Save Chart from the "File" menu to save the chart as a vector image. 
7. You can also use the tools embedded in the chart to Save, Copy, Print, Clone, 

Redraw and use Toolbox to edit the chart (Fig. 2). 
 

 
Fig. 2. Chart tools (Save, Copy, Print, Clone, Redraw, Toolbox). 
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10.3. Reaction Equations 
 
You can write almost any kind of reaction equation into the HSC 8 Reaction Equation box, 
see Fig. 3. Here are some examples of valid equation syntax: 
 

2Cu + S = Cu2S 

H2O = H(+a) + OH(-a) 

H2(g) = 2H(+a) + 2e- 

H2O = 0.5O2(g) + 2H(+a) + 2e- 

Ag = Ag(+a) + e- 

3NO2(-a) + 2H(+a) = 2NO(g) + H2O + NO3(-a) 

2Al(+3a) + 3S(-2a) + 6H2O = 2Al(OH)3 + 3H2S(g) 

 

 
Fig. 3. Input data for Reaction Equation calculations. 

Write the reaction equation into the box, see Fig. 3. If you have not given the stoichiometric 
coefficients for the species, you can press Balance to solve unknown coefficients. The 
balance button solves the coefficients on the basis of element balance equations. Therefore 
it cannot solve unknown coefficients if their number is larger than the number of elements in 
the corresponding reaction. 
 
Next to the Balance button, you may give a multiplier, which will be used to multiply all the 
coefficients in the reaction equation. The default value is 1, which means that the smallest 
stoichiometric coefficient in the reaction equation is 1. 
 
You can continue in the same way as in the One Chemical Formula option, see Chapter 10 
(section 10.1). 
 
Note that the Delta Format and Show Transitions options have no effect on the results, 
because the enthalpy and Gibbs energy of a reaction are in the Delta format by definition. 
HSC calculates the stoichiometry of the reaction given by the user, and points out errors if 
the element balance is incorrect. 
 
The example in Fig. 3 refers to the Mond process for refining impure nickel. In this process, 
raw impure nickel is first treated with CO gas at 60 °C to evaporate the nickel as a carbonyl 
gas. In the second stage, the temperature of the gas is increased to 200 °C to decompose 
the nickel carbonyl gas into pure metallic nickel and CO. This process works because the 
equilibrium of this reaction is on the right side (Equilibrium constant K > 1) at lower 
temperatures and on the left side (K < 1) at higher temperatures, Fig. 4. The reaction is 
exothermic (ΔH is negative) at all temperatures. 
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Fig. 4. Graphical results of Reaction Equation calculations. 

Vapor pressures p can be calculated by writing the reaction equation for the vaporization 
reaction concerned. For example, for pure magnesium the equilibrium is Mg = Mg(g). The 
activity aMg of pure magnesium is 1 and thus the vapor pressure in bar is equal to the 
equilibrium constant according to Eq. (11) in Chapter 8 Introduction and Eq. (1). See also 
Fig. 5 and Fig. 6. 
 

)(
)(

gMg
Mg

gMg p
a
p

K ==  (1) 

 
If a substance vaporizes into several polymers, all of them must be taken into account. The 
total vapor pressure is then the sum of all the individual partial pressures, if the gas phase 
behaves ideally. 
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Fig. 5. The equilibrium constant K is equal to the vapor pressure in bar according to Equation (1) if 
the activity of magnesium is 1. The boiling point of magnesium is about 1100 °C beyond which its 
vapor pressure exceeds 1 bar. 
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Fig. 6. Results for several reactions can be plotted into a single chart with Plot all data to help the 
comparison. 

You can also calculate more complicated reactions. First, write the reaction as shown in 
Fig. 7, then press Balance for the coefficients, see Fig. 8, and finally press Calculate for 
the results, see Fig. 9. Note that for aqueous ionic reactions, HSC also calculates the 
electrode potential versus Standard Hydrogen Electrode (E vs. SHE) if an electron (e-) is 
used in the formula. 
 

 
Fig. 7. Write the reaction equation without stoichiometric coefficients and press Balance. 

 
Fig. 8. Press Calculate to display the results. 
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Fig. 9. Results for an aqueous ionic reaction. 

The data used to calculate the results can be displayed by selecting a single substance in 
the Reaction Equation box, see Fig. 3 and then pressing Browse.... The database content 
is shown in Fig. 10. Species can be imported to the Reaction Equation module by adding 
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the species first in the Selected Species box at the bottom of the database browser and 
then clicking Import Items from the top panel of the browser. 
 

 
Fig. 10. The database browser window. 
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10.4. Reaction Equations Results 
 
The operation of the buttons in Fig. 1 and Fig. 2 were described in the previous chapter. 
The meaning of the results can be summarized as follows: 
 
1. If the equilibrium constant K is < 1 (or log(K) < 0), the reaction goes to the left. 
2. If the equilibrium constant K is > 1 (or log(K) > 0), the reaction goes to the right. 
3. A negative Enthalpy H of the reaction means that the reaction is exothermic, i.e. heat 

is released, Equation 7 in 8. Introduction. 
4. A positive Enthalpy H of the reaction means that the reaction is endothermic, i.e. heat 

is absorbed, Equation 7 in 8. Introduction. 
5. Delta Format has no effect on the results of reaction equations. 
6. In ionic reactions, potential E yields the electrochemical potential (in Volts) versus the 

Standard Hydrogen Electrode (SHE). Note, "e-" has to be included in the reaction. 
7. Equilibrium constant K is calculated using Equation (12) in 8. Introduction. 
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